Maven dependency for latest version

Follow

Originally posted by AndreaQ on 2013-05-17 14:23:05

Hi,
I'm starting developing with Cumulocity without OSGI, using java client libraries, but using this dependency I have an error:

  
    com.nsn.cumulocity.platform-services.sdk
    java-client-lib
    2.4.0
  
maybe related to a wrong POM, so, even if in your site looks that 2.4.0 is the latest version, I tried getting 2.5.0 version and it's ok, now I can build.
But I don't think even 2.5.0 is the latest version….
Searching with Google I found javadocs in http://resources.cumulocity.com/documentation/javasdk/2.0/index.html">http://resources.cumulocity.com/documen … index.html (but I wasn't able to find this link in your site) but I found even javadocs for 3.0 version.

So what is the correct Maven dependency for the latest version of java client library?
Thanks
Have more questions? Submit a request

Comments