Ask developer questions on


Hi there,

we encourage you to ask questions related to developing with Cumulocity on, using the tag "cumulocity". We will follow up on questions posted there just like we follow up on tickets, but the answers will be easier to find for others.

Kind regards,
Cumulocity Support


Have more questions? Submit a request


  • Avatar
    Sudhir Brahma

    I am unable to connect my Raspberry Pi 3 running the latest Rasbian OS (fresh install)
    The logs show: The agent still complains of "cumulocity-agent[1033]: Environment variable JAVA_HOME not set!"But when I do a echo $JAVA_HOME or echo $PATH all show correctly: '/usr/lib/jvm/java-8-oracle' and /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/lib/jvm/java-8-oracle/bin:/usr/lib/jvm/java-8-oracle/db/bin:/usr/lib/jvm/java-8-oracle/jre/bin respectively
    because of this, the agent is unable to read the /usr/share/cumulocity-rpi-agent/cfg/ file.
    There is an issue with this file as well. I did not find any instructions on how to populate its contents (but that will become imp only after the agent is able to read it- for now it is unable to do so). I did a tail -f /var/log/syslog to find this out.
    Net net: we need CLEAR instructions on how to connect a Rapberrry pi3 with a fresh install to the Cumulocity cloud, which sadly does not seem to be present on the Rasperry pi device site:

  • Avatar
    André Eickler

    Hi Sudhir,

    could you try to run the agent direclty from your command line? I.e.
    cd /usr/share/cumulocity-rpi-agent
    java -cp 'cfg/*:lib/*' -Dlogback.configurationFile=cfg/logback.xml c8y.lx.agent.Agent

    Does that work? What does it print?

    Kind regards,

  • Avatar
    Chaitanya K Jadcherla

    Hi Andre - I tried setting up my agent and tried to run as per your comments above, but couldn't connect to my tenant. I am getting an "Unable to open SPI device: No such file or directory" error when I look at the logs. All the other messages are warnings about device properties, which is not there and complaing about that . The other mesage is about tinker forge

  • Avatar
    André Eickler

    If I remember correctly, that error message relates to WiringPi not being installed on your Pi. It should not cause a problem. You can either install WiringPi or, if you are not using the I/O capabilities of your Pi, delete the piface-driver jar file from the agent.

    If you get complaints about missing properties, try running the agent as described above.


  • Avatar
    Nino Kalthoff

    first of all, thank you for the "tail -f /var/log/syslog" command. this helped a lot. I had the same issues and I've fixed them with following steps.

    Couldnt apply changes to usr/share/cumulocity-rpi-agent/cfg/
    1) change to the directory
    2) open the file with "sudo leafpad" or the texteditor of your choice

    Getting the error "Unable to open SPI device"
    1) open the Raspberry Pi Configuration
    2) enable "SPI"

    Another problem was that i get the error "Polling with wrong result"
    I fixed this, when I changed the host adress in the file
    from "host = https://..."
    to "host = http://..."
    I dont know why exactly https didnt worked

    Anyways, now the Raspberry is connected to cumulocity ive got the problem that I dont know what to do next. Is there any further documentation?
    I cant see the Raspberry under "All Devices" but i can change the permissions for the device. Thank you for your help.


    Edited by Nino Kalthoff